Volvo RTI MMM2

-aktualizacja oprogramowania
-polskie menu polska flaga
-możliwość aktualizacji nawigacji do najnowszej wersji

Pasuje do modeli:
-S80 (od 2006-2011)
-V70 (od 2007-2011)
-XC60 (od 2008-2010)
-XC70 (od 2007-2011)